
Lesson 1: 
This lesson demonstrates the use of DigiElch for running a C-Profile-Simulation for a cyclic voltammetric 

system (i.e. a simulation showing simultaneously how both the current curve and the associated concentration 

profiles are changing as function of the electrode potential). It also explains most of the commands available in 

the C-Profiles Menu and the options for customizing the appearance of the screen display and the drawing of the 

concentration profiles. It is assumed in the following that the user has worked trough Lesson0.pdf and that the 

file “CVSimSOcat.cvs” has been prepared and saved as described there. 

 

When working through the lesson, please, keep in mind that some menu commands may be disabled as long as 

DigiElch is running as trial installation.    
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1. Running a C-Profiles-Simulation 

1.1. Opening the CV-simulation document “CVSimSOcat.cvs” 

Start DigiElch and click on File -> Open select the file type CV-Simulation (*.cvs) in the appearing standard 

Windows file dialog and go to the folder where “CVSimSOcat.cvs” has been saved in Lesson0. In the example 

below it is assumed that this file has been saved in the 

folder “ElchSoft”. Continue with Open (“Öffnen”)  

 

 

 

 

 

 

When opening a CV-Simulation document or when creating a new one, the CV-Simulation Menu will be 

activated and the associated window shows the CV-current curves of all involved simulation objects as 

demonstrated in the above picture on the right-hand side. For running a C-Profiles-Simulation (i.e. a simulation 

showing simultaneously how both the current curve and the associated concentration profiles are changing as 

function of the electrode potential) it is necessary to leave the CV-Simulation Menu and to activate the C-

Profiles Menu.  

1.2. Activating the C-Profiles Menu 

The C-Profiles Menu is activated by clicking on View -> Active Simulation -> Concentration Profiles ( ) 

from within the CV-Simulation Menu. Unlike previous versions of DigiElch this command is always active 

(unless a simulation is just running) no matter whether the simulation of the CV-current curve has or has not yet 

completed. In the first case the C-Profiles Menu is activated and the concentration profiles referring to the end of 

the simulation are displayed on the left-hand side of the associated splitter window while the current curve is 

plotted on the right hand side of the splitter window as shown in the following picture. (The splitter window 

remains empty if the simulation object is empty or if the simulation has not yet been executed.) 

 

 
Figure 1 



1.3. Running a C-Profiles Simulation using the Fixed Grid Simulator, applying the Pause/Continue 

command and adapting the display speed 

If the simulation object is empty you must complete the input of the CV-Properties page (raised by clicking on 

Simulation -> Edit Properties ( )) before the command for running a C-Profiles Simulation is activated. This 

is not necessary for the simulations stored in the “CVSimSOcat.cvs”-file. Thus, you can directly click on 

Simulation -> Run -> Fixed Grid Simulator ( ) in order to see how the current curve and the concentration 

profiles are changing as function of the electrode potential. However, nowadays computer are usually so fast that 

it is hardly possible to see what is really happening. In most cases it is therefore a good idea to slow down the 

speed with which the concentration profiles are plotted.  Press down the right mouse button while the mouse 

cursor is localized over the left-hand part of the splitter window showing the concentration profiles.     

 

Go to Display Speed in the appearing Displaying C-Profiles-dialog 

box and move the pointer from the right-hand side to a mid-scale 

position and repeat Simulation -> Run -> Fixed Grid Simulator (

).  

The plotting of concentration profiles and current curve can be 

interrupted by clicking on Pause ( ). As long as the plotting is 

paused the menu command Pause is replaced by Continue. This 

enables the user to Pause and Continue plotting by clicking on one 

and the same menu command ( ).  

1.4. Setting of Breakpoints  

If the user wants to see the concentration profiles referring to a predefined value of the electrode potential it is 

more convenient to set a breakpoint (in the Displaying C-Profiles-dialog) as shown in the following picture. 

 

In this case the plotting is paused for the first time when reaching 

the potential E = - 0.5V. It continues by pressing Continue ( ) and 

stops again when reaching E = - 0.75V.  

The potential and current value referring to the actual display are 

shown as E(V)- and I(A)- couple on the right-hand side of the 

splitter window immediately beneath the window part showing the 

CV-current curve.  

 

1.5. Running a C-Profiles Simulation using the Adaptive Grid Simulator 

As outlined in Lesson0.pdf we generally recommend working with the Fixed Grid Simulator because of its 

robustness and efficiency resulting from the extraordinarily high exponential convergence as far as the flux 

(current) computation is concerned. It leads to the surprising result that the accuracy of the simulated current 

curve is much better than the accuracy of the simulated concentration profiles. Indeed, looking at Figure 1 

reveals that the concentration profiles were simulated on a coarse grid yielding sufficiently smooth concentration 

profiles only in the vicinity of the electrode surface while the concentration profiles are more and more 

approximated in the form of linear segments the greater the distance from the electrode. Increasing the number 

of boxes (grid points) in the Fixed Grid Simulator does not really overcome this problem because, due to the 

exponentially expanding grid, the maximum level of refinement is always introduced near the electrode.  

In a situation where the concentration profiles are of primary interest it is therefore more appropriate to use the 

Adaptive Grid (FEM) Simulator for keeping the local error in the concentration profiles below a predefined 

value no matter what the distance of the concentration point from the electrode surface is.  

 

In the present case Local FEM Error = 0.2 may be sufficient. Click on 

Simulation -> Edit Properties ( ), activate the Simulation Parameters page 

and enter this value. 

Then click on Simulation -> Run -> Adaptive Grid Simulator ( ). Only 15 additional grid points are 

introduced in the course of the simulation. Nevertheless, relatively smooth concentration profiles are now 

obtained over the entire distance.  

This is shown in the following picture referring to the second breakpoint, E = - 0.75V.  Of course, the profiles 

become smoother and smoother the smaller the value of Local FEM Error. Unfortunately, the optimal value can 

be hardly predicted in advance. In most cases it must be optimized by “trial and error”. The default value Local 

FEM Error = 0.005 may result in (unnecessarily) large numbers of grid points and computational costs.  



 

2. Saving the simulation document, saving the screen display, exporting current curve 

and concentration profiles  

2.1. Saving the simulation document 

All simulations involved in a simulation document can be saved by means of a standard Windows file dialog that 

appears when clicking on Document -> Save ( ) or Document -> Save As. The first command works “quiet” 

using the default path for saving the simulation document. The second command enables the user to save the 

document with a new name. Document -> Save As is used instead of Document -> Save if a new document (with 

an empty default path) is saved for the first time. Both commands are disabled as long as the simulation is 

running (even if it is paused).  

All chemical parameters and all simulation parameters (including the current curve) but not the settings for the 

screen display such as colors, fonts etc. are saved for each simulation. Note, however, that (unlike previous 

version of DigiElch) all simulated concentration profiles are stored in memory and written to the cvs-file when 

saving a simulation document after having completed a C-Profile Simulation.  It is therefore a big difference in 

the size of cvs-files saved before and after having completed a C-Profile Simulation.  The saving of all simulated 

concentration profiles is particularly useful when presenting results obtained with high computational costs 

(complex mechanisms comprising numerous species, systems requiring 2D-simulations) because the drawing of 

the concentration profiles can be immediately started without having to redo the simulation once more.  

2.2. Saving the screen display 

The graphics showing the concentration profiles on the screen can be saved as emf-file in enhanced Windows 

metafile format by clicking on Document -> Save Screen Display ( ) from within the C-Profiles Menu.  This 

command is active only if the drawing of the concentration profiles has been paused (either manually or by 

setting a breakpoint as described above in 1.3. and 1.4.). 

The screen display can be saved either in “black and white” or using the actual display colors (except the child 

window‟s background color which is always saved in white).  

Whether the first option or the second one is used depends on the default settings of 

Colors in emf-files which can be adjusted by clicking on View -> Preferences ( )   

 

 



The default type and size of the font used for labeling the axes in the emf-file can be adjusted independently of 

the screen font by means of a standard Windows font dialog that appears when clicking 

on emf-Files. The Fonts settings are available on the Preferences page raised by 

clicking on View -> Preferences ( )   

 

 

The Document -> Save Screen Display-command opens a slightly modified standard Windows file dialog. 

 

 

 

 

 

Clicking on the button Options enables the user to 

select whether the screen display is saved in “black 

and white” or using the actual screen colors. This 

selection applies only to the actual operation and 

does not overwrite the default settings of Colors in 

emf-files on the Preferences page. 

 

 

2.3. Exporting concentration profiles and/or CV-current curve 

The CV-current curve and/or the simulated concentration profiles can be exported in ASCII- format by applying 

the Simulation -> Export ( ) – command. This command is active only if the drawing of the concentration 

profiles has been paused (either manually or by setting a breakpoint as described above in 1.3. and 1.4.). It opens 

a slightly modified standard Windows file dialog   

 

 

 

 

 

 

 

The two different export options are described in the 

following: 

 

2.3.1. Export Option: E-I-couples (*.txt) 

Data exported in this way cannot be re-imported into DigiElch. The purpose of this export option is to export the 

actual state of the current curve (visible on the right-hand side of the splitter window) in a 

format that can be easily handled by third-party presentation software. For this purpose a 

few formatting options are provided.  

 

By default (i.e. when selecting this export filter and pressing directly the Export button in 

the Windows file dialog box shown in 2.3.) the current curve is exported in the form of 

voltage-current couples using the number-format and the separator selected in Exporting 

Data available on the Preferences page which is raised by clicking on  

View -> Preferences ( ). This selection can be temporarily overwritten (without 

changing the default settings in Exporting Data) by clicking on the Options button in the 

Windows file dialog box shown in 2.3. 



2.3.2. Export Option: c-x-couples (*.txt) 

This export option works analogously as described in 2.3.1 with the only difference that the actual state of the 

concentration profiles (visible on the left-hand side of the splitter window) is exported. The concentration 

profiles simulated for all species are exported in the following form  

 

general_header 

species_header_1 
x_1  separator  C_1_1 

x_2  separator  C_1_2 

. 

. 

x_N  separator  C_1_N 

species_header_2 

x_1  separator  C_2_1 

x_2  separator  C_2_2  

. 

. 

x_N  separator  C_2_N 

etc. 

 where N is the number of grid points used in the simulation.  

 general_header 

concentration profiles at E (V): E_Value 

number of species: Number_of_Species_Value  

 species_header_i 

species name: Name_of_species_i 

number of x (cm), C[Name_of_species_i] (m/l) couples: N    

 C_i_j is the concentration of the i-th species at the j-th grid point, and x_j is the distance of the j-th grid 

point from the electrode surface  

 Separator is one of the following characters: „Space‟, „Tab‟, „Comma‟ or „Semicolon‟  

 Numbers can be formatted using either point or comma.  

 The formatting of numbers and the separator can be specified by clicking on the Options button in the 

file dialog box. Otherwise, the default settings defined in the Preferences dialog are used. 

3. Customizing colors, fonts and the drawing of concentration profiles and cyclic 

voltammatric current curve 

The options for customizing colors, fonts and the drawing of the screen display are split into two groups: The 

first group involves options which apply to all windows associated with a CV-simulation document no matter 

whether CV-current curves, concentration profiles ore fitting objects are displayed.  The second group applies 

only to the display shown in the left- or right-hand side of the splitter window associated with the C-Profiles 

Menu. 

3.1. Customizing options applying to all windows 

These options are compiled on the Preferences page which appears by clicking on View -> Preferences ( ).  

 

 

 

 

 

 

 

 

The options for Colors in emf-files have already been described in 2.2. The remaining options work as follows: 



Fonts 

The default font and its size used for labeling the axes can be adjusted independently for screen display, printing 

and for the saving of the screen graphics in emf-format by means of the standard Windows font dialog that 

appears when clicking on the associated text field. 

  

Colors 

The default colors for drawing the info-text, for labeling axes as well as the child-window‟s background color 

and the color of dialog boxes can be adjusted by means of the standard Windows color dialog box that appears 

when clicking on the associated color field. The color shown in the field associated with Dialog boxes is only 

used if use standard dialog colors has not been selected. Otherwise, the color settings of the operating system are 

used for all DigiElch‟s dialog boxes. Note that changing the color settings for Dialog boxes and Child window 

takes effect only after creating/opening a new dialog box/child window. 

 

Drawing 
This selection decides whether a normal or a thick pen is used for printing, storing emf-files and drawing the 

screen display. 

 

Example: 

The settings for Fonts, Colors and Drawing shown above beneath 3.1. lead to the display of  Figure 1 in 1.2. 

Using the following settings  

 

   

 

 

 

 

 

 

 

 

results in 

 

 
 

 

Resetting the default colors: 

The default colors can be reset by clicking on View -> Reset Default Colors in DigiElch’s start menu. The latter 

is active only immediately after starting DigiElch or when closing all child windows. 

 

 



3.2. Customizing options applying only to the display shown in the left- or right-hand side of the C-

Profiles splitter window  

Depending on whether the mouse cursor is localized over the left- or right hand side of the splitter window, a 

click on the right mouse button raises one of the following dialog boxes  

 

Displaying C-Profiles 

The adjustment of the Display Speed and the setting of Breakpoints has already been described above in 1.3. and 

1.4., respectively. 

The effect of Labels and Background is best explained by comparing the following to pictures:  

 

The left picture refers to the settings of Labels and Background shown above, the right picture refers to the 

following settings 

 
 

 

 

 

 

 

 

 

 

 

 

 



Displaying Current Curves 

 

Options 

 Classical/IUPAC 

if Classical is selected negative potentials are drawn from left to right and the cathotic current is 

positive. Otherwise positive potentials are drawn from left to right and the cathotic current is negative 

 Total current/Current density 

Either the total current or the current density is plotted. 

 Show all simulations/Show active simulation 

This option has no effect as long as the C-Profiles Menu is activated. In this case only the active 

simulation is plotted on the right-hand side of the C-Profiles splitter window. However, the selection 

will be taken over when returning to the CV-Simulation Menu. 

 

Colors  

The default colors for drawing the background, the active CV, the inactive CV and the inactive cycles (segments) 

of the active CV can be adjusted by means of the standard Windows color dialog box that appears when clicking 

on the associated color field. The selection for the inactive CV will be taken over when returning to the CV-

Simulation Menu. 

  

Labels 
The default labels (E(V) and I(A)) used in the text that appears immediately beneath the display of the CV-

current curve can be modified by changing the text in the associated text field.  

 
3.3. Customizing the colors used for drawing the individual concentration profiles 

Double-clicking the left mouse button while the mouse cursor is 

localized over the rectangle where the name of a particular species 

appears under Species on the right-hand side of the splitter window 

opens a standard Windows color dialog box that can be used for 

modifying the color with which the concentration profile of that 

species is drawn. 

 

 

4. Running a C-Profiles Simulation for a 2D-electrode geometry 

Running a C-Profiles Simulation for a 2D-electrode geometry works analogously as described in 1.3.  

 

However, in that case the spin control Show box number in Display 

Speed of the Displaying C-Profiles-dialog box is activated. This 

enables the user to select the y-direction for which the concentration 

profiles are plotted. In the present case, the electrode geometry refers to 

a disk electrode and the concentration profiles drawn on the screen 

refer to the third box in y-direction (i.e. parallel to the electrode 

surface). The distance of all these concentration points from the center 

of the electrode is given in Distance/Radius, i.e. expressed in parts of 

the electrode radius.   


