
Lesson 3: 
This lesson uses the experimental data files included in the Fitting.cvs – file (which is installed together with 

DigiElch) for demonstrating how the potential steps used during data fitting can be individually specified for 

each target file. Note that experimental CVs are usually measured with small potential steps (less than or equal to 

1 mV). In version 2 of DigiElch exactly the same potential steps were used by the fitting procedure. Such an 

approach becomes very time consuming if dozens of experimental CVs are involved in a fitting project and the 

optimal mechanism or sensible starting values are not yet known. DigiElch 4 enables the user to execute the data 

fitting with a diluted data set by selecting fitting potential steps which are different from the experimental ones.  

 

For the purposes of this lesson real experimental CVs referring to the electrochemical reduction of a nickel 

chelate complex (denoted as NiL) in the absence and presence of 2,2'-dipyridyl  (denoted as DP) have been 

imported into CV-simulation documents. The following files are included in the Lesson 3.zip archive: 

 NiLACN.cvs  

Real experimental CVs of NiL measured in acetonitrile (without DP).  

 

 NiLDP1.cvs, NiLDP2.cvs, NiLDP3.cvs, NiLDP4.cvs, NiLDP5.cvs, NiLDP6.cvs 

Real experimental CVs of NiL in the presence of 6 different DP concentrations 

 Start.cvs  

CV-Simulation document containing an estimated mechanism and sensible starting parameters. 

 

Please work through Lesson1 to learn how to prepare ASCII-files (use-files) which can be imported by DigiElch.  

 

It is assumed that the reader of this lesson has already worked to the previous lessons and is familiar with basic 

operations such as entering, editing and deleting reaction equations. When working through the lessons, please, 

keep in mind that a few menu commands are disabled in the not activated program running as trial installation.  

  



Using the RAM-Disk for setting up the fitting project 
I. Start DigiElch 

II. Open ( ) the file NiLACN.cvs included in the Lesson 3.zip archive. (In order to see that analytical 

concentrations for a species NiL and a species DP are really stored in this file click on Simulation -> Edit 

Properties ( ). The appearing dialog box shows all parameters imported from the experimental use-file)  

 

III. Click on Document->Add Simulations to RAM-Disk(), enter “ACN” as Identification String in the 

appearing dialog box and continue with OK 

 

The Identification String helps us to distinguish RAM-disk files 

referring to different documents. The string may be empty. In the 

present case the prefix “ACN” indicates files referring to 

experiments conducted in acetonitrile.   

 

 

IV. Repeat II and III for the files NiLDP1.cvs, NiLDP2.cvs, NiLDP3.cvs, NiLDP4.cvs, NiLDP5.cvs, NiLDP6.cvs 

but enter “DP1”, “DP2”, “DP3”, “DP4”, “DP5” and “DP6” as Identification String.  

 

All experimental data are internally saved now in the RAM-DISK used by the fitting procedure. It is therefore a 

good idea to save the RAM-DISK content to avoid steps the repetition of II to IV when restarting/resuming data 

fitting. Thus click on Document->Save RAM-Disk to save the RAM-Disk content let’s say as “Data.rmd”. Then 

close all open documents before continuing. 

Fitting the charge transfer parameters in the absence of DP 

The NiL complex exhibits a (quasi) reversible one-electron reduction step in acetonitrile in the absence of DP. 

Thus, in the first step we are going to setup a fitting project for a simple charge-transfer mechanism using only 

the target CVs referring to acetonitrile (Identification String “ACN”) in the absence of DP.  

 

1. Generate a new ( ) CV-Simulation document and click on Data Fitting -> Prepare Fitting Project to 

activate the Fitting Menu. Then enter the following mechanism and starting parameters 

 

 

 

 

 

Make sure that standard potential, E° (V), and heterogeneous rate constant, ks (cm/s), are selected for being 

optimized by the fitting procedure (see Lesson2 point 10 for more details). The selection is indicated by 

plotting the associated parameter value in magenta.  

Also make sure that the diffusion coefficient of NiL has been selected for being optimized and that it is 

linked to the diffusion coefficient of species NiL
-
 as shown in the following picture (see Lesson2 point 11 

for more details) 

 

The analytical concentration entered for NiL is imported from the experimental files during data fitting. The 

value entered in Canal does therefore not matter but at least one analytical concentration must be different 

from zero to enable the Run command for the fitting procedure.  

  



2. Click Data Fitting -> Select Target Curves from RAM-Disk ( ), select all files with the prefix “ACN” to 

the List of Selected Files and finish with Ok.  

 

 

Note that the prefix defined in the Identification String and the 

extension _RAM_i (i is an index) is added to each file name in order 

to ensure that  

 it can be easily recognized to which experiment the file refers 

  a unique file name is generated 

 

 

 

 

 

 

 

 

 

 

 

3. In principle data fitting could be started now by clicking on Data Fitting->Run Fitting Procedure ( ). In 

that case, data fitting is executed using the same 1-mV-potential steps as in the experiment. The following 

must be done if we want that larger potential steps, let’s say 5 mV, are used in the course of data fitting. 

 

4. Click on Data Fitting->Modify Selected Target Files and enter 0.005 in the input filed labelled as Potential 

steps (V) as shown below.  

 

 

Note that the entered value applies only to the 

simulations executed during data fitting for 

reproducing the experimental CV indicated in the 

dialog box’s title. That means, the value of 

Potential steps (V) needs not to be the same for 

each file. This option provides a high flexibility. In 

the present case (where the same value is used for 

each file) it is somewhat tedious. Click on the Next 

File button to activate the data referring to the next 

file and enter 0.005 again. 

 

Click on OK if all files are done. 

 

Remark: 

 The modifications entered in the above dialog box do not affect the RAM-DISK files. Thus when re-

selecting these files (as described in 2.) all modifications must be entered again. 

 The modification of the potential steps can be done only once. After having replaced Potential steps (V) 

=0.001 with Potential steps (V)=0.005 it is not possible to undo this modification by applying the Data 

Fitting->Modify Selected Target Files command again. In order to avoid the accumulation of rounding 

errors, the input field Potential steps (V) is disabled after each modification because the original current 

curve is replaced by an interpolated one. A new modification can be accomplished only by applying the 

Data Fitting -> Select Target Curves from RAM-Disk ( ) command twice: 1) remove all files from 

the List of Selected Files and leave with OK, 2)  re-select the respective files.  

  



5. Before starting data fitting with the Data Fitting->Run Data Fitting ( ) – command, click on View -> 

Preferences ( ) and  select the following options for Drawing and Controlling Data Fitting 

 

 

 

 

 

 

 

 

6. Use the commands in the Simulation -> Compare  Simulation with Experiment – menu to see (summarized 

in a single window) how well experimental and simulated CVs agree.  
 
Select the couple displayed on the screen by means 

of the Simulation -> Compare  Simulation with 

Experiment -> Select Couple ( ) – command. 
Then click on  Simulation -> Compare  Simulation 

with Experiment -> Show Next Couple ( ) and 

select ( ) this couple, too.  (Note that a selection 

can be undone by means of the Simulation -> 
Compare  Simulation with Experiment -> Clear 

Selection ( )-command). If all couples have 

been selected in this way, click on Simulation -> 
Compare  Simulation with Experiment -> Show all 

Selected Couples. It makes that all selected couples 

are displayed in a new window as shown in the 
picture. After closing this window, the Fitting Menu 

and the associated splitter window is reactivated 
again. 

 

 

 

The time saving effected by using higher potential steps is not very impressive for this example because 

only 6 files are involved in the fitting project and the simulations are extremely fast for a mechanism 

containing only two species. For this reason, the procedure is repeated now for a more sophisticated fitting 

example. 

 

Fitting all experimental CVs on the basis of a square scheme 

7. Close all open child windows (or quit DigiElch but make sure that the RAM-DISK has been saved before as 

described in IV. If you want to continue later, restart DigiElch and load the “Data.rmd” RAM-DISK file. 

Note that the commands File -> Load RAM-Disk and Document -> Load RAM-Disk are enabled only if the 

RAM-DISK is empty.) 

8. Open the “Start.cvs” file included in the “Lesson 3.zip archive.  This file contains a template for a square 

scheme mechanism formulated with the required species names NiL and DP. It also contains sensible 

starting parameters and parameters selected for being optimized by the fitting procedure. What still remains 

to be done is the selection of the target CVs. Make sure that the experimental CVs are stored in the RAM-

DISK, click on Data Fitting -> Prepare Fitting Project examine the proposed mechanism and starting 

parameters. Close the dialog and select the target CVs as described in 2. but select the entire set of 

experimental CVs not only the ones measured in acetonitrile in the absence of DP. 

  



 

9. Click on View -> Preferences ( ), activate the option save optimized parameter file as shown below and 

select a path for this file by clicking on the Browse  

 

 

 

Selecting save optimized parameter file 

makes that a file named “optimal.cvs” 

containing the parameter set of the “best 

fit” is stored in the directory which is 

D:\Temp\Lesson 3 in the example 

shown on the left. 

 

 

 

 

 

10. Start data fitting for the unmodified files by clicking on Data Fitting->Run Data Fitting ( ). The fitting is 

executed now using the original potential steps of 1mV. Even on a fast computer it may take 10 or more 

minutes before the fitting procedure has found the “best fit parameters”. Note that a sensible mechanism and 

starting parameter are usually not known. It is therefore rather unlikely that satisfactory results are already 

obtained with the first trial. It makes therefore sense to speed up the fitting procedure by using larger 

potential steps. 

 

11. Deselect the option save optimized parameter file (see 9.)  in order to ensure that the parameter set of the 

best fit obtained with 1 mV potential steps is not overwritten when restarting the data fitting. 

 

12. Modify all experimental target CVs as described above in 4. in order to accomplish that potential steps of 5 

mV are used in all simulations executed by the fitting procedure. 

13. Restart data fitting for the modified files by clicking on Data Fitting->Run Data Fitting ( ). The 

procedure is about five times faster yielding virtually in the same optimized parameter set. The latter 

becomes visible by comparing the optimized values regained for each parameter using 5mV steps with those 

stored in the optimal.cvs file referring to 1mV. 

 

 

 

 

Remark: 

The approximation of the time derivatives implemented into DigiElch 

is 4
th

 order accurate. Using potential steps of 5 or even 10 mV has 

therefore a relatively small effect on the accuracy of the simulations 

but the experimental data are diluted. For this reason we consider 

potential steps of 5 mV the optimal choice for balancing speed and 

accuracy of the fitting process in most cases.  

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 


